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1. Introduction 
 
The SSC Tool is provided by ETG (EtherCAT Technology Group) and used for generate EtherCAT SSC 
(Slave Stack Code). Any legal ETG members can use this tool to generate several workable SSC sample 
codes that provide by BECKHOFF or other companies, or they also can specify their application through the 
tool. This guide will describe how to import the configuration file of particular application and generate related 
source files. 
 
Note1: ASIX configuration file is based on SSC Tool v5.13 
Note2: Please make sure your system has Microsoft EXCEL 2013 or later before using SSC Tool 
Note3: This article will use AX58200 “Ethercat_GPIO_AIO_Reference_Design” project as an example. 
 
if you’ll use other reference design project, please adjust the path as below of project, configuration and Excel 
file by yourself. 
 
⚫ AX58100_BSP 

◼ Ax58100_GpioAio 
BSP_ROOT\SampleCode\Ax58100_GpioAio\For_SSC_Tool\AX58100_GPIO_8Bit_AIO_16Bit.esp 
BSP_ROOT\SampleCode\Ax58100_GpioAio\For_SSC_Tool\Import\Configuration\AsixAx58100GpioAioConfigurations.xm
l 
BSP_ROOT\SampleCode\Ax58100_GpioAio\For_SSC_Tool\Import\Configuration\files\AX58100_GPIO_8Bit_AIO_6Bit.xls
x 

 
◼ Ax58100_MotorControl 

BSP_ROOT\SampleCode\Ax58100_MotorControl\For_SSC_Tool\AX58100_MotorControl.esp 
BSP_ROOT\SampleCode\Ax58100_MotorControl\For_SSC_Tool\Import\Configuration\AX58100_MotorControlConfigurati
ons.xml 
BSP_ROOT\SampleCode\Ax58100_MotorControl\For_SSC_Tool\Import\Configuration\files\AX58100_MotorControl.xlsx 

 
⚫ AX58200_BSP 

◼ Ethercat_GPIO_AIO_Reference_Design 
BSP_ROOT\SampleCode\Ethercat_GPIO_AIO_Reference_Design\For_SSC_Tool\AX58200_GPIO_8Bit_AIO_16Bit.esp 
BSP_ROOT\SampleCode\Ethercat_GPIO_AIO_Reference_Design\For_SSC_Tool\Import\Configuration\AsixAx58200Gpi
oAioConfigurations.xml 
BSP_ROOT\SampleCode\Ethercat_GPIO_AIO_Reference_Design\For_SSC_Tool\Import\Configuration\files\AX58200_G
pioAio.xlsx 

 
◼ Ethercat_MotorControl_Reference_Design 

BSP_ROOT\SampleCode\Ethercat_MotorControl_Reference_Design\For_SSC_Tool\AX58200_MotorControl.esp 
BSP_ROOT\SampleCode\Ethercat_MotorControl_Reference_Design\For_SSC_Tool\Import\Configuration\AsixAx58200M
otorControlConfigurations.xml 
BSP_ROOT\SampleCode\Ethercat_MotorControl_Reference_Design\For_SSC_Tool\Import\Configuration\files\AX58200_
MotorControl.xlsx 

 
⚫ AX58400_BSP 

◼ Ax58400_GpioAio 
BSP_ROOT\SampleCode\Ax58400_GpioAio\For_SSC_Tool\AX58400_GPIO_8Bit_AIO_16Bit.esp 
BSP_ROOT\SampleCode\Ax58400_GpioAio\For_SSC_Tool\Import\Configuration\AsixAx58400GpioAioConfigurations.xm
l 
BSP_ROOT\SampleCode\Ax58400_GpioAio\For_SSC_Tool\Import\Configuration\files\AX58400_GPIO_8Bit_AIO_16Bit.xl
sx 

 
◼ Ax58400_MotorControl 

BSP_ROOT\SampleCode\Ax58400_MotorControl\For_SSC_Tool\AX58400_MotorControl.esp 
BSP_ROOT\SampleCode\Ax58400_MotorControl\For_SSC_Tool\Import\Configuration\AX58400_MotorControlConfigurati
ons.xml 
BSP_ROOT\SampleCode\Ax58400_MotorControl\For_SSC_Tool\Import\Configuration\files\AX58400_MotorControl.xlsx 
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2. Download The SSC Tool 
 
You can download the SSC Tool through below hyperlink: 
ETG_SSC_Tool_Download 
 
Click the link (red square) of below screen. 

 

Figure 2-1 

 
You must be an ETG member for download any contents from ETG website. 
Please type your “User name”, “Password” and click “Login” for download. 

 

Figure 2-2 

  

https://www.ethercat.org/en/downloads/downloads_01DCC32A10294F2EA866F7E46FB0285F.htm


 

 
 

c 
7 

Copyright (C) 2021-2024 Reserved by ASIX Electronics Corporation 
 

AX58x00 
SSC Tool Configuration Import User Guide 

  
 

Reference Design User Guide 

Type the EtherCAT Vendor ID of your company and click “Submit Registration *”. 

 

Figure 2-3 

 
Type “First Name”, “Last Name”, “Company”, “Email”, check “Data Privacy” and click “Submit”. 

 

Figure 2-4 
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You will see below screen and receive the email later. 

 

Figure 2-5 

 
You should click the download link in the received email and you will see below screen for download page. 

 

Figure 2-6 
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3. SSC Tool Installation 
 
Below is an example how to install SSC Tool. Execute “EtherCAT Slave Stack Code Tool.exe”. 

 

Figure 3-1 

 
Select the language and click “OK”. 

 

Figure 3-2 

 
Click “Next >”. 

 

Figure 3-3 
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Check “I accept …” and click “Next >” 

 

Figure 3-4 

 
Type the “Organization”, “Vendor ID” and click “Next >”. 

 

Figure 3-5 
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Click “Install”. 

 

Figure 3-6 

 
Wait a while for installation. 

 

Figure 3-7 
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Click “Finish”. 

 

Figure 3-8 

 
The SSC Tool shortcut already exists in your start menu. 

 

Figure 3-9 
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4. Import Configuration File 
 
If the old configuration already be imported in SSC Tool of your environment, please do below 2 steps for 
remove it. If your SSC Tool is first time to execute, please see next page. 
 
Step 1: Click “Tool -> Options” 

 

Figure 4-1 

 
Step 2: Select the configuration item, click “-” icon and “OK”. 

 

Figure 4-2 
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If your SSC Tool is first time to execute and you will see below screen. If you removed old configuration as 
above-mentioned, just click “File -> New”, you will also see below screen. 
Please select “Custom” field and click “Import”. 

 

Figure 4-3 

 
Select the configuration file in the path below and click “Open”. 
“BSP_ROOT\SampleCode\Ethercat_GPIO_AIO_Reference_Design\For_SSC_Tool\Import\Configuration
\AsixAx58200GpioAioConfigurations.xml” 

 

Figure 4-4 
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You will see below screen. The “ASIX AX58200 | 8BIT GPIO, 16BIT AIO <ASIX Electronic Corporation>” 
appears in the Custom filed. Please click “OK”. 

 

Figure 4-5 

Click “Yes”. 

 

Figure 4-6 

 
It will back to main screen of SSC Tool. Please click “Tool -> Application -> Import”. 

 

Figure 4-7 

 
Select the excel file in the path below and click “Open”. 
“BSP_ROOT\SampleCode\Ethercat_GPIO_AIO_Reference_Design\For_SSC_Tool\Import\Configuration
\files\AX58200_GPIO_8Bit_AIO_16Bit.xlsx” 
 
Then press “OK” to close excel file parsing logger dialog. 
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Save this SSC project by click “File -> Save As”. 

 

Figure 4-8 

 
You can overwrite the file in 
“BSP_ROOT\SampleCode\Ethercat_GPIO_AIO_Reference_Design\For_SSC_Tool\AX58200_GPIO_8Bit
_AIO_16Bit.esp”. 

 

Figure 4-9 
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It will come back to main screen. Click “Project -> Create new Slave Files”. 

 

Figure 4-10 

 
Then here will start to generate SSC source code, before press the “Start” button, please check the file paths 
are correct. 
If the code generation is successfully as the figure below, click “OK” and “Close” to finish the procedure. 

 

Figure 4-11 
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Then the generated source code can be found as below. 

 

Figure 4-12 
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Evaluation Board License Agreement 
 

By using this evaluation board or kit (together with all associated software, hardware and documentation 
provided by ASIX, collectively, the "Evaluation Board"), you ("You") agree to be bound by the terms and 
conditions of this Evaluation Board License Agreement ("Agreement "). Do not use the evaluation board until 
you have read and agreed to this agreement. Your use of the Evaluation Board constitutes your acceptance 
of this Agreement. 
 
License: 
ASIX Electronics (“ASIX”) grants you the right to use the accompanying evaluation board, which provides 
limited functionality, for the sole purpose of evaluating and testing ASIX products for your evaluation and 
testing purposes in a research and development environment. Under no circumstances should the evaluation 
board be assembled, directly or indirectly, as part of any of your products, as it has been developed for 
evaluation purposes only and has no direct functionality and is not a finished product. 
 
Notice: 
(1) The description of hardware circuit, software tools and other related information in this document are only 

used to illustrate the operation of application examples for ASIX Electronic products. You are solely 
responsible for the use of such circuits, software and information in the design of your equipment. ASIX 
Electronics is not responsible for any losses arising out of the use of the circuit, software or information by 
you or a third party. 

(2) ASIX Electronics has taken reasonable care in describing the information in this document, but ASIX 
Electronics does not warrant that such information is error-free. ASIX Electronics disclaims all liability for 
any damages you may suffer as a result of errors or omissions in the information contained herein. 

(3) ASIX Electronics shall not be liable for infringement of patents, copyrights or other intellectual property 
rights of third parties due to the use of ASIX Electronics products or the technical information described in 
this document. No license, express or implied, or otherwise, is granted under any patent, copyright or 
other intellectual property rights of ASIX Electronics or others. 

(4) You may not alter, modify, copy or otherwise misappropriate any ASIX electronic product, whether in 
whole or in part. ASIX Electronics shall not be liable for any loss incurred by you or a third party as a 
result of altering, modifying, copying or otherwise misappropriating ASIX Electronics products. 

(5) You should use the ASIX Electronic products described in this document within the range specified by 
ASIX Electronic, especially the maximum rating, operating power supply voltage range, mobile power 
supply voltage range, heat radiation characteristics, installation and other product characteristics. ASIX 
Electronics accepts no liability for malfunctions or damages resulting from use of ASIX Electronics 
products outside of such designations. 

(6) When using ASIX electronic products, please comply with all applicable laws and regulations that regulate 
the inclusion or use of controlled substances, including but not limited to the EU RoHS Directive. ASIX 
Electronics disclaims all liability for damage or loss resulting from your failure to comply with applicable 
laws and regulations. 

(7) The buyer or distributor of ASIX electronic products is responsible for distributing, disposing of or 
otherwise placing the product to a third party, and notifying the third party of the contents and conditions 
specified in this document in advance, ASIX Electronics shall not be liable for any loss suffered as a result 
of authorized use of ASIX Electronics products. 

(8) This document may not be reproduced or reproduced in any form, in whole or in part, without the prior 
written consent of ASIX Electronics. 
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Copyright ©  2021-2024 ASIX Electronics Corporation. All rights reserved.  
 
DISCLAIMER 
 
No part of this document may be reproduced or transmitted in any form or by any means, electronic or 
mechanical, including photocopying and recording, for any purpose, without the express written permission of 
ASIX. ASIX may make changes to the product specifications and descriptions in this document at any time, 
without notice.  
 
ASIX provides this document “as is” without warranty of any kind, either expressed or implied, including 
without limitation warranties of merchantability, fitness for a particular purpose, and non-infringement.  
 
Designers must not rely on the absence or characteristics of any features or registers marked “reserved”, 
“undefined” or “NC”. ASIX reserves these for future definition and shall have no responsibility whatsoever for 
conflicts or incompatibilities arising from future changes to them. Always contact ASIX to get the latest 
document before starting a design of ASIX products.  
 
TRADEMARKS  
  
ASIX, the ASIX logo are registered trademarks of ASIX Electronics Corporation. All other trademarks are the  
property of their respective owners.  
 
EtherCAT®  is a registered trademark and patented technology, licensed by Beckhoff Automation GmbH, 
Germany.   
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